Remotedesktop Lizenzzierungsserver

Mitglied: Leffe69

Leffe69 (Level 1) - Jetzt verbinden

Feb 25, 2021 um 13:01 Uhr, 757 Aufrufe, 13 Kommentare

Hallo!

Ich habe zwei Win Server ohne AD:

Win 2019 Standard - Auf diesem sind die RDS Zugriffslizenzen installiert.

Win 2008 R2 - Dieser soll sich die Lizenzen vom 2019er holen.

Dazu habe ich bereits den 2019er in den Gruppenrichtlinien als Lizenzserver für den 2008 eingetragen.

Versuche ich jetzt vom Remotedesktoplizenzs-Manager eine Verbindung zum 2019er herzustellen bekommen
ich verschiedene Fehlermeldung:

"Der Vorgang kann nicht ausgeführt werden. Zuigriff verweigert."

Dabei wird der Server in der Liste links aber angezeigt.

"Verbindung mit "2019er Server" konnte nicht hergestellt werden. Der Lizenzserver ist nicht verfügbar"

Dabei hat der 2019er Lizenzserver noch gestern Lizenzen für Clients ausgestellt, der sich auf dem 2008R2 angemeldet hat?

Danke für jeden Hinweis!

Gruß
Leffe
Mitglied: Luci0815
Feb 25, 2021 um 14:13 Uhr
Soweit ich weiß, muss der RDS dann auch auf dem Server 2019 laufen. Die beiden Server vertrauen sich gegenseitig doch nicht, wenn sie nicht in einer Domäne sind.
Bitte warten ..
Mitglied: Leffe69
Feb 25, 2021 um 16:25 Uhr
Sie sind ja in der gleiche Workgroup. Domäne gibt es bei mir ja nicht.

Und es hat ja bis gestern auch gegeht.

Ich meine es hat was mit der TLS Version zu tun.

Hab auch TLS 1.2 bereits auf dem Server aktiviert. Brachte aber auch keinen Erfolg.

Gruß
Leffe
Bitte warten ..
Mitglied: ukulele-7
Feb 25, 2021 um 16:34 Uhr
Wurden Updates installiert? Windows 2008 R2 ist seit 1+ Jahr EOL und der Windows 2019 könnte ihm daher den Zugriff verweigern.
Bitte warten ..
Mitglied: erikro
Feb 25, 2021 um 17:53 Uhr
Moin,

das geht nicht. Ab 2012R2 (wenn ich mich recht entsinne) muss der Lizenzserver und der RD-Server in einem AD sein oder der Lizenzserver auf dem RD-Server mit installiert werden. Glaube es mir. Ich hatte das Gleiche Problem und viel Hirnschmals verschwendet, um es doch hinzubasteln. Keine Chance.

hth

Erik
Bitte warten ..
Mitglied: erikro
Feb 25, 2021 um 17:54 Uhr
Zitat von @Leffe69:
Und es hat ja bis gestern auch gegeht.

Sind vielleicht gestern die 180 Tage abgelaufen?
Bitte warten ..
Mitglied: jsysde
Feb 25, 2021 um 21:01 Uhr
N'Abend.

Zitat von @erikro:
[...]muss der Lizenzserver und der RD-Server in einem AD sein oder der Lizenzserver auf dem RD-Server mit installiert werden.[...]
So isses. Siehe z.B. hier:
https://www.virtualizationhowto.com/2020/06/windows-server-2019-remote-d ...

[...]For a simple Windows Server 2019 remote desktop services without domain installation, you simply need to add the Remote Desktop Licensing and Remote Desktop Session Host role services.[...]

Cheers,
jsysde
Bitte warten ..
Mitglied: Leffe69
Feb 25, 2021 um 21:01 Uhr
Dazu kann ich nur sagen, dass es bei mir genai so schon funktioniert hat.

Mein Lizenzserver hat ja auch noch gestern Lizenzen für den 2008R2 ausgestellt.

Bis ich so weit war, hat es auch lange gedauert.

Leider habe ich mir nicht genau gemerkt was ich genau gemacht habe.

Ich meine aber ich hätte auf dem 2019er Server TLS 1.0 aktiviert, damit der 2008R2 zugreifen konnte.

Und damit der 2019 Lizenzserver lief habe ich in der Registry irgendeinen Hash Wert gelöscht.

Alles Anweisugnen aus dem Netz.

Aktuell ist es aber auch so, dass ich auch auf den 2019er keine RDP Verbindungen mehr machen kann
und beim Anmelden nach einen Neustart wieder die Fehlermedlung kommt, dass der Lizenserver nicht gefunden wurde.

Wobei im Lizenzmanager alles richtig aussieht.

Das ganze hat scheinbar ein Update am Montag verursacht. Das habe ich jetzt zwar inzwischen deinstalliert, hat aber so erst mal nichts gebracht.

Scheinbar versucht MS mit updates den Betrieb eines RDS-Servers ohne AD zu verhindern.

Gruß
Leffe
Bitte warten ..
Mitglied: ukulele-7
Feb 26, 2021 um 07:19 Uhr
Zitat von @Leffe69:

Das ganze hat scheinbar ein Update am Montag verursacht. Das habe ich jetzt zwar inzwischen deinstalliert, hat aber so erst mal nichts gebracht.

Scheinbar versucht MS mit updates den Betrieb eines RDS-Servers ohne AD zu verhindern.


Ich würde MS viel unterstellen aber in diesem Fall ist ein nicht supportetes Setup durch eine Änderung per Update nicht mehr lauffähig. Das Update hat vielleicht nur eine Sicherheitslücke geschlossen aber wohl eher nicht absichtlich deine Installation unbrauchbar gemacht. Auf nicht unterstützte Installationen testen würde ich von MS auch nicht erwarten.

Du kannst beide Server aus der Datensicherung vor dem Update holen...
Bitte warten ..
Mitglied: erikro
Feb 26, 2021 um 14:59 Uhr
Moin,

Zitat von @Leffe69:

Dazu kann ich nur sagen, dass es bei mir genai so schon funktioniert hat.

Mein Lizenzserver hat ja auch noch gestern Lizenzen für den 2008R2 ausgestellt.

Achso, so rum geht es. Ich hatte das so verstanden, dass der 2008R2 der Lizenzserver und der 2019 der TS ist.

Ich meine aber ich hätte auf dem 2019er Server TLS 1.0 aktiviert, damit der 2008R2 zugreifen konnte.

Besser TLS 1.1 und 1.2 auf dem 2008R2 aktivieren. Guckst Du hier:
https://www.kernel64.com/tls-1-1-sowie-tls-1-2-auf-windows-server-2008-r ...

Und damit der 2019 Lizenzserver lief habe ich in der Registry irgendeinen Hash Wert gelöscht.

Tja, keine Ahnung, welcher das gewesen sein könnte. ;-) face-wink

Aktuell ist es aber auch so, dass ich auch auf den 2019er keine RDP Verbindungen mehr machen kann

Jetzt habe ich wieder den Eindruck, dass der 2019er der RD-Server ist. Was denn nun?

und beim Anmelden nach einen Neustart wieder die Fehlermedlung kommt, dass der Lizenserver nicht gefunden wurde.

Wo?

Wobei im Lizenzmanager alles richtig aussieht.

Wo?

Scheinbar versucht MS mit updates den Betrieb eines RDS-Servers ohne AD zu verhindern.

Das ist von MS schon lange nicht mehr gewollt.

Liebe Grüße

Erik
Bitte warten ..
Mitglied: Leffe69
Feb 26, 2021 um 17:08 Uhr
Sorry für die Verwirrung!

Habe mir zunächst so beholfen, dass ich auf dem Win20089R2 jetzt eigene Lizenzen installaiert haben und er
jetzt selber sein eigener Lizenzserver ist.

Ebenso der 2019er Server.

Hier habe ich noch gesehen, dass er beim Start den Fehler ausgabe, dass der Remotedesktoiodienst nicht gestartet werden konnte.

Das mit der Meldung "Fehler beim Starten des Remotedesktopdiensts. Relevanter Statuscode: 0x8007045B."

Dazu hatte ich gelsen, dass man überprüfen soll, ob die Diensta auf "Autostart" stehen. Was sie nicht taten.

Hab das ebenfalls geändert.

Toi, toi, toi.

Im Moment scheibt alles soweit zu laufen...

Gruß
Leffe
Bitte warten ..
Mitglied: Leffe69
Feb 26, 2021 um 18:09 Uhr
Wenn ich noch was fragen darf...?

Ich habe den Win2008R2 ja neu aufgesetzt, weil ich recht viel alte RDP-Clients (bunter Mischmasch von HP-Clients) habe, die aufgrund ihrer RDP-Software sich nicht mit neueren als Win2008R2 verbinden können.

Nun habe ich also aktuelle einen "alten" 2008er und einen "neuen" 2008er.

Einige Clients können sich nun bei gleicher Verbindungseinstellung auf dem Client mit dem alten verbinden,
aber nicht mit dem Neuen.

Bei beiden steht die Systemeigenschaft bei Remote gleich. Siehe ScreeShot.

Gibt es noch weitere Einstellungen, die die Verbindung vom alten und neuen Server unterscheiden können?

Danke!!!!

Gruß
Leffe
bildschirmfoto 2021-02-26 um 18.07.37 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: ukulele-7
Mar 01, 2021 um 15:15 Uhr
Ich kann dir bedingt folgen, warum du jetzt zwei RD-SH unter Windows 2008 R2 hast ist mir noch nicht ganz klar.

Alte RDP-Client Versionen können sich aber sehr wohl auch mit neueren Servern verbinden, ich glaube es reicht am Server unter
Computerkonfiguration \ Richtlinien \ Administrative Vorlagen \ Windows-Komponenten \ Remotedesktopdienste \ Remotedesktopsitzungs-Host \ Sicherheit
Benutzerauthentifizierung mit Authentifizierung auf Netzwerkebene ist für Remoteverbindung erforderlich zu deaktivieren. Ich hatte längere Zeit ein Windows XPe (ich glaube RDP <= 6.0) das sich auf Windows 2012 R2 als RD-SH anmelden konnte.
Bitte warten ..
Mitglied: Leffe69
Mar 01, 2021 um 15:33 Uhr
Ich habe einen alten Win2008 und eine neuen aufgesetzt. Brauche aber zwei separate Server.

Das mit der Authentifizierung hatte ich auf dem neuen auch schon so eingestellt. Siehe letzten Screenshot.

Die WBTs von HP mit denen ich auf den neuen 2008er zugreifen will, können mit ihrem RDP Client auch nur bis Win2008.

Warum sie sich aber mit dem alten 2008er verbinden können und mit dem neuen nicht bleibt die Frage.

Die RDP Versionen der beiden Server können ja nicht unterschiedlich ein?

Was könnte denn noch der Unterschied im Verbindungsaufbau sein? Hat TLS was damit zu tun?

Danke!

Gruß
Leffe
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes8814 hours agoQuestionWindows 1036 Comments

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
solved JiggyLee9 hours agoQuestionOff Topic16 Comments

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Windows User Management
Account Aktivierung über VPN
Phill931 day agoQuestionWindows User Management3 Comments

Hallo, ich muss mir für eine RDP Umgebung für einen Verein eine Lösung für die Account Aktivierung ausdenken. Meine Idee ist die folgende: 1. ...

Switches and Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
solved Oggy011 day agoQuestionSwitches and Hubs8 Comments

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetaller11 hours agoTipHumor (lol)8 Comments

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Windows Server
GPU Passthrough HYPER-V 2019
bintes1 day agoQuestionWindows Server7 Comments

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORY1 day agoQuestionVideo & Streaming10 Comments

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
Windows Admin Center DC
maximid1 day agoQuestionWindows Server3 Comments

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...