Mikrotik mAP WLAN - LAN bridge

Mitglied: Phill93

Phill93 (Level 1) - Jetzt verbinden

Jun 10, 2021 um 16:49 Uhr, 482 Aufrufe, 8 Kommentare, 1 Danke

Hallo,

ich kämpfe hier mit einem Mikrotik mAP, mein Ziel ist eine Bridge zwischen WLAN und LAN zu Bauen. Wenn ich das wlan1 Interface Standalone nutze komme ich ins Netz, sobald dieses auf der bridge hängt geht nichts mehr.

Hat jemand eine Ahnung was ich falsch mache?

Gruß

Phill93


Mitglied: colinardo
LÖSUNG Jun 10, 2021, aktualisiert um 18:09 Uhr
Servus
add bridge=bridgeLocal broadcast-flood=no interface=wlan1
Du filterst mit der Option Broadcast-Traffic was aber DHCP/ARP & Co beeinflussen kann.
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Port_Settings
# jan/02/1970 00:57:05 by RouterOS 6.45.8
Und hier ist eindeutig ein Update fällig! 6.48.3 ist zum jetzigen Zeitpunkt die aktuelle stable. Dazwischen wurden übrigens auch diverse Wifi Fixes veröffentlicht.
/interface wireless cap
set bridge=bridgeLocal discovery-interfaces=bridgeLocal interfaces=wlan1
Verwendest du den Capsman in Kombination mit dem mAP ?

/ip firewall filter
add action=accept chain=input
add action=accept chain=output
Die sind überflüssig, der Standard der Firewall des Mikrotik ist per Default "Accept" auf allen chains wenn es keine Regeln gibt.


Meine Empfehlung: Zu aller erst mal ein RouterOS Update fahren, dann das Gerät resetten "ohne" die Default Config zu laden (/system reset-configuration no-defaults=yes skip-backup=yes) und Step by Step via Winbox neu konfigurieren, dann fluppt das problemlos.

Grüße Uwe
Bitte warten ..
Mitglied: Phill93
Jun 11, 2021 um 09:31 Uhr
Hallo,

Ich hab jetzt das Gerät wie von dir beschrieben resettet, da waren viele Relikte von Versuchen drauf. Ich hab das Gerät jetzt auf die aktuelle LTS v6.47.10 aktualisiert.

Trotz sauberer Config kann ich von dem Gerät das Gateway nicht pingen, komischer weiße bekomme ich aber eine IP per DHCP zugewiesen. Geräte die an ether1, ether2 hängen bekommen keine.

Hier mal meine aktuell Config:


Bitte warten ..
Mitglied: Phill93
Jun 11, 2021 um 09:34 Uhr
Die Verbindung zum WLAN klappt:


Bitte warten ..
Mitglied: colinardo
LÖSUNG Jun 11, 2021, aktualisiert um 10:03 Uhr
Öhm was hast du eigentlich vor? Du hast das WiFi als "Station" konfiguriert statt als AP? Möchtest du den LAN Teilnehmern Netzzugang über WLAN ermöglichen?
Wenn ja das geht so nicht mit einem Mikrotik fremden AP weil der Mode "station-bridge" nicht mit fremden APs im 802.11 Mode in einer LAN-Bridge funktioniert. Siehe
https://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes.
https://forum.mikrotik.com/viewtopic.php?t=144424
Hier musst du dann am besten Routing machen, also die Client-Ports ein neues Subnetz vergeben und Routen statt zu bridgen. Es geht zwar mit dem Mode pseudobridge, aber das wird dann mit einem mAP lahm ohne Ende.
Bitte warten ..
Mitglied: Phill93
Jun 11, 2021 um 09:57 Uhr
Hallo,

Ja ich möchte den LAN Teilnehmern (2 Messgeräte) Netzzugang über WLAN ermöglichen. Das Problem ist das ich die Geräte über IP erreichen muss, routing ist da nicht möglich.
Bitte warten ..
Mitglied: colinardo
LÖSUNG Jun 11, 2021, aktualisiert um 10:08 Uhr
Zitat von @Phill93:
Das Problem ist das ich die Geräte über IP erreichen muss, routing ist da nicht möglich.
?? Klar sind Rechner per IP und Routing erreichbar, du meinst wohl nur per Layer 2 statt Layer3, denn nur wenn Broadcast-Traffic zur Verbindung nötig ist wäre eine Bridge auch nötig !
S. die zusätzlichen Links und Ergänzungen im letzten Post. Wenn du unbedingt eine L2 Domain bilden musst dann wirst du wohl zum "Pseudobride-Mode" des Wifi Interfaces greifen müssen, aber das geht nur mit einem Device am LAN Port, aber nicht wundern wenn der mit einem mAP sehr langsam ist, der hat ziemlich wenig CPU Power, die nötig ist weil dieser dann in jedem Paket die MACs verändern muss!
Bitte warten ..
Mitglied: Phill93
Jun 11, 2021 um 10:05 Uhr
Hallo,

ich hab den mAP jetzt im Pseudobridge-Mode laufen und es funktioniert.

Die Performance ist hier zweitrangig da die Messgeräte nur ein 10Mbit Interface haben und hier nur ab und zu Daten verschicken. Ich werd jetzt einfach noch einen zweiten mAP besorgen und den zweiten LAN Port am mAP deaktivieren.

Danke für die Hilfe
Bitte warten ..
Mitglied: colinardo
Jun 11, 2021, aktualisiert um 10:09 Uhr
OK, na dann :-) face-smile
Danke für die Hilfe
Immer gerne.

Grüße Uwe
Bitte warten ..
Heiß diskutierte Inhalte
Internet
Sehr große Dateien über das Internet versenden
solved pd.edv1 day agoQuestionInternet113 Comments

Hallo, ich muss immer wieder große Daten über das Internet übertragen - da werden viele am WeTransfer & Co. denken aber mit den winzigen ...

Hardware
MiniPC Empfehlung AliExpress
winlin1 day agoGeneralHardware24 Comments

Hallo Zusammen, Hat schon mal jemand hier einen Mini pc bei AliExpress gekauft und kann einen empfehlen??? Suche etwas wo ich 2vms problemlos virtualisieren ...

Microsoft
User Aktivitäten
Roadmax1 day agoQuestionMicrosoft13 Comments

Hallo Zusammen, ich möchte gerne automatisiert auf jedem Windows 10 PC im Netzwerk prüfen lassen, was der User dort live treibt. Konkret geht es ...

Windows 10
Custom Windows-10-ISO bauen (in kontinuierlicher Verbesserung) - Ausgabe 2021
beidermachtvongreyscull1 day agoTutorialWindows 102 Comments

Editorial kleines Vorwort Ich hoffe, ich habe hier eine für den ein oder anderen Kollegen interessante Lösung zusammengestellt. Alles, was Ihr hier lest, ist ...

Cloud services
Server mieten - wo?
ZZaaiiggaa12 hours agoQuestionCloud services9 Comments

Hallo zusammen, suche einen Windows Server für SQL zum mieten, mit mindestens: 256GB SSD 32GB Ram Welche Anbieter eignen sich am besten? Und muss ...

Notebook & Accessories
Lenovo Dockingstation - Kompatibilität?
solved Visucius1 day agoQuestionNotebook & Accessories10 Comments

Guten Morgen, wir habens ja gerade mit antiquierter Technik ;-) Vor mir steht ein T440s Lenovo-Laptop, der nen frisches Windows 7 ähh Quatsch Windows ...

Windows 10
Dokumentenmanagement-System für den Heimgebrauch
Pineapple2713 hours agoQuestionWindows 104 Comments

Hallo zusammen, kennt jemand ein gutes Dokumentenmanagement-System für den Heimgebrauch und hat eventuell auch schon Erfahrungen damit gemacht? Da ich es rein privat nutzen ...

LAN, WAN, Wireless
Suche fuer unser Reihenmittelhaus eine "gute" WLAN-Abdeckung
homenet1 day agoQuestionLAN, WAN, Wireless3 Comments

Hallo, suche fuer unser Reihenmittelhaus eine "gute" WLAN-Abdeckung. Benoetigt fuer: Smartphones, Laptops, Radio - max. ca. 10 Geraete gleichzeitig, ueblicherweise ca. 4 Geraete dauernd ...