DHCP Relay N2024

Mitglied: dellfreak

dellfreak (Level 1) - Jetzt verbinden

Jun 09, 2021 um 16:30 Uhr, 544 Aufrufe, 7 Kommentare

Wir möchten mit unsern Windows 2019 DHCP Server über unsern Dell Switch N2024 ein DHCP Relay aufbauen.

Eckdaten:

DHCP Server Port 3 / 192.168.100.10

VLAN 100 Port 14 / 192.168.100.x

VLAN 200 Port 13 / 192.168.200.x

Und VLAN 200 nimmt keine IP Adresse an.

Konfig lautet:

configure
vlan 100,200
exit
slot 1/0 1 ! Dell EMC Networking N2024
stack
member 1 1 ! N2024
exit
interface vlan 1
ip address 192.168.100.10 255.255.255.0
exit
interface vlan 100
ip address 192.168.100.1 255.255.255.0
exit
interface vlan 200
ip address 192.168.200.1 255.255.255.0
ip helper-address 192.168.100.10
exit
!
interface Gi1/0/13
switchport access vlan 200
dhcp relay - Klicke auf das Bild, um es zu vergrößern
Mitglied: NixVerstehen
Jun 09, 2021, aktualisiert um 17:06 Uhr
Servus,

ich hab zwar als Nicht-ITler einen eher laienhaften Blick, aber warum liegt dein DHCP-Server im VLAN1 mit 192.168.100.10
und dein VLAN 100 hat 192.168.100.0/24?

Gruß NV

Edit: Das ist doch dasselbe Netz mit zwei unterschiedlichen VLAN-ID's?
Bitte warten ..
Mitglied: aqui
Jun 09, 2021, aktualisiert um 17:28 Uhr
Das ist auch der grobe Konfig Fehler in diesem Switch Setup. Doppelte IP Netze in den beiden VLAN Segmenten sind ein absolutes NoGo ! Da wurde schon gegen die einfachsten Grundlagen einer simplen IP Adressierung verstoßen.
Folglich kann das so nicht funktionieren.
Das der Switch solch grob fehlerhafte Konfig überhaupt übernimmt spricht auch Bände über die Firmware bzw. Kommando Parser bei den gruseligen Switchgurken von Dell. Billiges OEM von Accton, was erwartet man also... :-( face-sad
Bitte warten ..
Mitglied: NixVerstehen
Jun 09, 2021 um 17:41 Uhr
Uff...ich hab es richtig erkannt. Hatte schon Angst, das es vom Meister wieder eine "Watsch'n" gibt :-) face-smile
@aqui Aber um als Laie auch etwas zu lernen: Warum erhalten die Clients im VLAN 100 dann eine Adresse per DHCP?
Bitte warten ..
Mitglied: dellfreak
Jun 10, 2021 um 09:25 Uhr
Vielen Dank für die Info. Dann werde ich das VLAN 100 erstmal rausnehmen.
Bitte warten ..
Mitglied: NixVerstehen
Jun 10, 2021 um 09:47 Uhr
Ich hab's zwar nicht so mit der CLI, aber wenn ich deine Konfig oben richtig deute, dann hast du dem Switch im VLAN 1 außerdem die Adresse 192.168.100.10 gegeben, die du auch deinem Server zugewiesen hast. Das kann natürlich in keiner Weise funktionieren.

Wenn du die IP des Servers so belassen willst, dann stell den Server ins VLAN 100, nimm die Clients aus dem VLAN 100 und setz die meinetwegen in ein VLAN 300.

Switch:

VLAN 1 - Netz 192.168.1.0/24 - Interface IP 192.168.1.1 (untagged / Management-VLAN)
VLAN 100 - Netz 192.168.100.0/24 - Interface IP 192.168.100.1
VLAN 200 - Netz 192.168.200.0/24 - Interface IP 192.168.200.1
VLAN 300 - Netz 192.168.300.0/24 - Interface IP 192.168.300.1

Dann im Switch noch das DHCP-Relay auf 192.168.100.10, auf dem Server die DHCP-Scopes anlegen, idealerweise dem DHCP das Schreiben in DNS gewähren (mit einem separaten Benutzerkonto) und dann läuft das ja. In ein Konfig-File kannst du es selbst packen, ich hab's nicht mehr so mit dem CLI.

Gruß NV
Bitte warten ..
Mitglied: dellfreak
Jun 11, 2021 um 16:41 Uhr
Es lag daran, die IP Pakete kamen zum DHCP Server an, der konnte Sie nicht verarbeiten. Da der DHCP Server nicht im IP Kreis der VLANs war.
Bitte warten ..
Mitglied: aqui
Jun 11, 2021, aktualisiert um 17:12 Uhr
Da der DHCP Server nicht im IP Kreis der VLANs war.
Ohh man...an solche Banalitäten denkt man schon gar nicht mehr in einem Adminitrator Forum. Ist ja so als ob man in den Urlaub will aber vergessen hat zu tanken !!
Trotzdem mutig das du dich hier mit sowas geoutet hast ! Respekt !

Dennoch ist auch dein IP Setup oben mit der doppelten IP Adressierung ein kapitaler Konfig Fehler der niemals so bleiben sollte !! Das verstößt gegen alle Standards.
Wie gesagt, das der Dell vom Kommando Parser so einen fatalen Unsinn überhaupt zulässt und nicht wie bei allen anderen üblich mit einer Konfig Error Meldung reagiert, spricht natürlich auch ne deutliche Sprache zu dieser Gruselhardware... :-( face-sad Das kann jeder Chinesen Switch vom Blödmarkt besser.
Case closed !
Bitte warten ..
Heiß diskutierte Inhalte
Internet
Sehr große Dateien über das Internet versenden
solved pd.edv1 day agoQuestionInternet113 Comments

Hallo, ich muss immer wieder große Daten über das Internet übertragen - da werden viele am WeTransfer & Co. denken aber mit den winzigen ...

Hardware
MiniPC Empfehlung AliExpress
winlin1 day agoGeneralHardware24 Comments

Hallo Zusammen, Hat schon mal jemand hier einen Mini pc bei AliExpress gekauft und kann einen empfehlen??? Suche etwas wo ich 2vms problemlos virtualisieren ...

Microsoft
User Aktivitäten
Roadmax1 day agoQuestionMicrosoft11 Comments

Hallo Zusammen, ich möchte gerne automatisiert auf jedem Windows 10 PC im Netzwerk prüfen lassen, was der User dort live treibt. Konkret geht es ...

Windows 10
Custom Windows-10-ISO bauen (in kontinuierlicher Verbesserung) - Ausgabe 2021
beidermachtvongreyscull1 day agoTutorialWindows 102 Comments

Editorial kleines Vorwort Ich hoffe, ich habe hier eine für den ein oder anderen Kollegen interessante Lösung zusammengestellt. Alles, was Ihr hier lest, ist ...

Cloud services
Server mieten - wo?
ZZaaiiggaa11 hours agoQuestionCloud services9 Comments

Hallo zusammen, suche einen Windows Server für SQL zum mieten, mit mindestens: 256GB SSD 32GB Ram Welche Anbieter eignen sich am besten? Und muss ...

Notebook & Accessories
Lenovo Dockingstation - Kompatibilität?
solved Visucius1 day agoQuestionNotebook & Accessories10 Comments

Guten Morgen, wir habens ja gerade mit antiquierter Technik ;-) Vor mir steht ein T440s Lenovo-Laptop, der nen frisches Windows 7 ähh Quatsch Windows ...

LAN, WAN, Wireless
Suche fuer unser Reihenmittelhaus eine "gute" WLAN-Abdeckung
homenet1 day agoQuestionLAN, WAN, Wireless3 Comments

Hallo, suche fuer unser Reihenmittelhaus eine "gute" WLAN-Abdeckung. Benoetigt fuer: Smartphones, Laptops, Radio - max. ca. 10 Geraete gleichzeitig, ueblicherweise ca. 4 Geraete dauernd ...

Windows 10
Dokumentenmanagement-System für den Heimgebrauch
Pineapple2712 hours agoQuestionWindows 104 Comments

Hallo zusammen, kennt jemand ein gutes Dokumentenmanagement-System für den Heimgebrauch und hat eventuell auch schon Erfahrungen damit gemacht? Da ich es rein privat nutzen ...